Probando VTGO-PC con entornos VoIP Cisco

Lo que haremos en esta práctica será conectar un softphone VTGO-PC y configurarlo para que se comporte como un Cisco 7960 y conectarlo con el resto de la maqueta.

Como se puede ver en la captura que ponemos a continuación, es relativamente sencillo que a través del software VTGO podamos emular un Cisco 7960 que forme parte de la red de voz sobre IP.

VTGO como Cisco 7960
VTGO como Cisco 7960

Realizamos llamadas entre los diferentes teléfonos y habilitamos debugs, para ver los mensajes de depuración según vayan transcurriendo las llamadas.

Vídeo explicativo del laboratorio VTGO-PC con entornos VoIP Cisco

Equipamiento del laboratorio VoIP con softphones IP Blue y Cisco IP Communicator

El equipamiento que forma parte del laboratorio es:

  • Aplicación IP Blue VTGO-PC trabajando como Cisco 7960.
  • 2 Cisco IP Communicator instalados en máquinas virtuales diferentes Windows XP.
  • VMWare Workstation para servir el escenario emulado.
  • GNS3 con chasis de Cisco 3725 (C3725-ADVIPSERVICESK9-M) IOS  12.4(15)T14.
  • Wireshark para capturar los paquetes de la llamada.

 Escenario del laboratorio VTGO-PC con entornos VoIP Cisco

Lo que haremos es conectar los elementos de red comentados y dotarlos de configuración para que se puedan comunicar entre si.

maqueta VoIP con VTGO Cisco
maqueta VoIP con VTGO Cisco

Explicación de el entorno de emulación VTGO-PC con entornos VoIP Cisco en la maqueta de GNS3

  • El CUCME estará trabajando sobre un chasis de un Cisco 3725.
  • El SW será otro Cisco 3725 pero con una tarjeta de 16 puertos.
  • Una nube irá conectada al interfaz Loopback del Windows anfitrión.
  • Otra nube irá conectada al interfaz VMNet1 de los Windows XP.

Con todo ello y una vez comprobadas las infraestructuras se puede realizar la configuración del equipamiento.

Configuraciones ejemplo para montar la maqueta VTGO-PC con entornos VoIP Cisco dentro de GNS3

Configuración del switch de infraestructura:


!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname SW
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$D1Ni$jalwZ1RlA9L/ONamo9O65/
!
no aaa new-model
memory-size iomem 5
no ip routing
no ip icmp rate-limit unreachable
no ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!

Parte de servicio del switch


username cisco privilege 15 password 7 060506324F41
archive
log config
hidekeys
!
!
!
!
ip tcp synwait-time 5
ip ssh version 1
!
!
!
!
interface FastEthernet0/0
no ip address
no ip route-cache
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
no ip route-cache
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
description conexion CUCME
switchport mode trunk
!
interface FastEthernet1/1
description conexion Phone.2 WXP1 WXP2
switchport access vlan 20
switchport voice vlan 10
!
interface FastEthernet1/2
description conexion Phone.1
switchport access vlan 20
switchport voice vlan 10
!

Parte de acceso al switch por telnet:


!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
login local
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
exec-timeout 0 0
logging synchronous
login local
line vty 5 903
exec-timeout 0 0
logging synchronous
login local
!

Configuración del router trabajando como CME de VoIP


!
hostname CUCME
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$mPS/$c7CROeXcLkjUKV9SAzmds.
!
no aaa new-model
memory-size iomem 5
clock timezone utc 22 30
no ip icmp rate-limit unreachable
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.10.1 192.168.10.5
ip dhcp excluded-address 192.168.20.1 192.168.20.5
!
ip dhcp pool Voice
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
option 150 ip 192.168.10.1
!
ip dhcp pool Data
network 192.168.20.0 255.255.255.0
default-router 192.168.20.1
option 150 ip 192.168.20.1
!
!
no ip domain lookup
!
multilink bundle-name authenticated

Acceso y routing del equipamiento:

!
username cisco privilege 15 password 7 00071A150754
username cisco11 privilege 15 password 7 121A0C0411045D557B7A
archive
log config
hidekeys
!
!
!
!
ip tcp synwait-time 5
ip ssh version 1
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.0
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.20.1 255.255.255.0
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
router rip
version 2
network 192.168.10.0
network 192.168.20.0
no auto-summary
!
ip forward-protocol nd
!
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 600 life 86400 requests 86400
ip http path flash:/gui
!
no cdp log mismatch duplex
!
!

Configuración parte de la telefonía que se integrará al escenario VoIP del que tratamos:

!
telephony-service
video
max-ephones 20
max-dn 20
ip source-address 192.168.10.1 port 2000
auto assign 1 to 20
service phone videoCapability 1
max-conferences 8 gain -6
transfer-system full-consult
directory entry 1 100 name Alberto Fernandez
directory entry 2 101 name Carlos Martin
directory entry 3 103 name Miguel Lucent
create cnf-files version-stamp 7960 Mar 02 2002 11:13:29
!
!
ephone-dn 1 dual-line
number 100
label Alberto Fernandez (100)
!
!
ephone-dn 2 dual-line
number 101
label Carlos Martin (101)
!
!
ephone-dn 3 dual-line
number 103
label Miguel Lucent (103)
!
!
ephone-dn 4
number A100
label Intercom Tecnicos VoIP
intercom A101
!
!
ephone-dn 5
number A101
label Intercom Tecnicos VoIP
intercom A100
!
!
ephone-dn 6
number 106
park-slot timeout 10 limit 1 transfer 106
description "Created this DN por timeout"
!
!
ephone 1
device-security-mode none
description Alberto Fernandez
video
mac-address 000C.294F.8D3D
type CIPC
button 1:1 2:3 3:4 4:2
!
!
!
ephone 2
device-security-mode none
description Carlos Martin (101)
mac-address 0200.4C4F.4F50
type 7960
button 1:2 2:4
!
!
!
ephone 3
device-security-mode none
description Miguel Lucent (103)
video
mac-address 000C.2955.1703
type CIPC
button 1:3 3:5
!

Comando de acceso al equipo y servidor NTP


!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
login local
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
exec-timeout 0 0
privilege level 15
logging synchronous
login local
transport input telnet ssh
line vty 5 903
exec-timeout 0 0
privilege level 15
logging synchronous
login local
transport input telnet ssh
!
ntp master 2
!
end

Comandos de comprobación de servicio VoIP entre los softphones

Activamos debugs para ver el intercambio de capacidades de los dispositivos VoIP


CUCME#
Mar 1 16:42:20.971: ephone-1[1]:CapabilitiesRes received
Mar 1 16:42:20.975: ephone-1[1][SEP000C294F8D3D]:Caps list 11
Unrecognized Media Type 89 1 ms
G711Ulaw64k 60 ms
G711Alaw64k 60 ms
Unrecognized Media Type 86 60 ms
G722_56k 20 ms
G722_64k 20 ms
G729 60 ms
G729AnnexA 60 ms
G729AnnexB 60 ms
G729AnnexAwAnnexB 60 ms
Unrecognized Media Type 257 1 ms

Mar 1 16:42:20.983: ephone-3[2]:UpdateCapabilitiesMessage
CUCME#
Mar 1 16:42:27.191: New Skinny socket accepted [2] (3 active)
Mar 1 16:42:27.195: sin_family 2, sin_port 52477, in_addr 192.168.20.8
Mar 1 16:42:27.195: skinny_add_socket 2 192.168.20.8 52477

Comprobación de los teléfonos que están registrados actualmente:


CUCME#show ephone

ephone-1 Mac:000C.294F.8D3D TCP socket:[1] activeLine:0 REGISTERED in SCCP ver 20 and Server in ver 8
mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:1 caps:11
IP:192.168.20.7 1100 CIPC keepalive 123 max_line 8
button 1: dn 1 number 100 CH1 IDLE CH2 IDLE
button 2: dn 3 number 103 CH1 IDLE CH2 IDLE shared
button 3: dn 4 number A100 auto dial A101 CH1 IDLE shared
button 4: dn 2 number 101 CH1 IDLE CH2 IDLE shared
ephone-2 Mac:0200.4C4F.4F50 TCP socket:[3] activeLine:0 REGISTERED in SCCP ver 12 and Server in ver 8
mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:1 caps:7
IP:192.168.20.8 54253 Telecaster 7960 keepalive 396 max_line 6
button 1: dn 2 number 101 CH1 IDLE CH2 IDLE shared
button 2: dn 4 number A100 auto dial A101 CH1 IDLE shared
ephone-3 Mac:000C.2955.1703 TCP socket:[2] activeLine:0 REGISTERED in SCCP ver 20 + Video and Server in ver 8
mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:1 caps:11
IP:192.168.20.9 1076 CIPC keepalive 149 max_line 8
button 1: dn 3 number 103 CH1 IDLE CH2 IDLE shared
button 3: dn 5 number A101 auto dial A100 CH1 IDLE

 

Probando VTGO-PC con entornos VoIP Cisco
5 (100%) 6 votos

Dejar respuesta

Please enter your comment!
Please enter your name here